What’s Vulnerable › Vulnerabilities
CVE-2019-12728
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-04 · updated 2026-06-17
- Weakness: CWE-494
Description
Grails before 3.3.10 used cleartext HTTP to resolve the SDKMan notification service. NOTE: users' apps were not resolving dependencies over cleartext HTTP.
Affected products
- grails-core: before 3.3.10 — fixed in 3.3.10
How to fix
Upgrade to a fixed version: grails-core 3.3.10. Check the vendor advisory for mitigations.
References
- https://github.com/grails/grails-core/issues/11250
- https://objectcomputing.com/news/2019/05/30/possible-grails-mitm-vulnerability
- https://github.com/grails/grails-core/issues/11250
- https://objectcomputing.com/news/2019/05/30/possible-grails-mitm-vulnerability
Get alerted when CVE-2019-12728 or the next vulnerability affects your stack