What’s Vulnerable › Vulnerabilities
CVE-2019-12730
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-04 · updated 2026-06-17
- Weakness: CWE-908
Description
aa_read_header in libavformat/aadec.c in FFmpeg before 3.2.14 and 4.x before 4.1.4 does not check for sscanf failure and consequently allows use of uninitialized variables.
Affected products
- FFmpeg: before 3.2.14 — fixed in 3.2.14
How to fix
Upgrade to a fixed version: FFmpeg 3.2.14. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109317
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/9b4004c054964a49c7ba44583f4cee22486dd8f2
- https://git.ffmpeg.org/gitweb/ffmpeg.git/shortlog/n4.1.4
- https://github.com/FFmpeg/FFmpeg/commit/ed188f6dcdf0935c939ed813cf8745d50742014b
- https://github.com/FFmpeg/FFmpeg/compare/a97ea53...ba11e40
- https://seclists.org/bugtraq/2019/Aug/30
- https://security.gentoo.org/glsa/202003-65
- https://usn.ubuntu.com/4431-1/
- https://www.debian.org/security/2019/dsa-4502
- http://www.securityfocus.com/bid/109317
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/9b4004c054964a49c7ba44583f4cee22486dd8f2
- https://git.ffmpeg.org/gitweb/ffmpeg.git/shortlog/n4.1.4
Get alerted when CVE-2019-12730 or the next vulnerability affects your stack