What’s Vulnerable › Vulnerabilities
CVE-2019-12735
- Severity: high (CVSS 8.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-05 · updated 2026-06-17
- Weakness: CWE-78
Description
getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_fails or nvim_input in Neovim.
Affected products
How to fix
Upgrade to a fixed version: Neovim 0.3.6; vim/vim 8.1.1365. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00075.html
- http://www.securityfocus.com/bid/108724
- https://access.redhat.com/errata/RHSA-2019:1619
- https://access.redhat.com/errata/RHSA-2019:1774
- https://access.redhat.com/errata/RHSA-2019:1793
- https://access.redhat.com/errata/RHSA-2019:1947
- https://bugs.debian.org/930020
Get alerted when CVE-2019-12735 or the next vulnerability affects your stack