What’s Vulnerable › Vulnerabilities
CVE-2019-12741
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-05 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS exists in the HAPI FHIR testpage overlay module of the HAPI FHIR library before 3.8.0. The attack involves unsanitized HTTP parameters being output in a form page, allowing attackers to leak cookies and other sensitive information from ca/uhn/fhir/to/BaseController.java via a specially crafted URL. (This module is not generally used in production systems so the attack surface is expected to be low, but affected systems are recommended to upgrade immediately.)
Affected products
- FHIR Hapi Fhir: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: FHIR Hapi Fhir 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/jamesagnew/hapi-fhir/commit/8f41159eb147eeb964cad68b28eff97acac6ea9a
- https://github.com/jamesagnew/hapi-fhir/issues/1335
- https://github.com/jamesagnew/hapi-fhir/releases/tag/v3.8.0
- https://github.com/jamesagnew/hapi-fhir/commit/8f41159eb147eeb964cad68b28eff97acac6ea9a
- https://github.com/jamesagnew/hapi-fhir/issues/1335
- https://github.com/jamesagnew/hapi-fhir/releases/tag/v3.8.0
Get alerted when CVE-2019-12741 or the next vulnerability affects your stack