What’s Vulnerable › Vulnerabilities
CVE-2019-12779
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-07 · updated 2026-06-17
- Weakness: CWE-59
Description
libqb before 1.0.5 allows local users to overwrite arbitrary files via a symlink attack, because it uses predictable filenames (under /dev/shm and /tmp) without O_EXCL.
Affected products
- ClusterLabs Libqb: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: ClusterLabs Libqb 1.0.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00031.html
- http://www.securityfocus.com/bid/108691
- https://access.redhat.com/errata/RHSA-2019:3610
- https://bugzilla.redhat.com/show_bug.cgi?id=1695948
- https://github.com/ClusterLabs/libqb/issues/338
- https://github.com/ClusterLabs/libqb/releases/tag/v1.0.4
- https://github.com/ClusterLabs/libqb/releases/tag/v1.0.5
- https://security.gentoo.org/glsa/202107-03
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00027.html
Get alerted when CVE-2019-12779 or the next vulnerability affects your stack