What’s Vulnerable › Vulnerabilities
CVE-2019-12822
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-14 · updated 2026-06-17
- Weakness: CWE-119
Description
In http.c in Embedthis GoAhead before 4.1.1 and 5.x before 5.0.1, a header parsing vulnerability causes a memory assertion, out-of-bounds memory reference, and potential DoS, as demonstrated by a colon on a line by itself.
Affected products
- EmbedThis GoAhead: before 4.1.1; from 5.0.0 before 5.0.1 — fixed in 4.1.1, 5.0.1
How to fix
Upgrade to a fixed version: EmbedThis GoAhead 4.1.1, 5.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/embedthis/goahead/compare/5349710...579f21f
- https://github.com/embedthis/goahead/issues/285
- https://github.com/embedthis/goahead/compare/5349710...579f21f
- https://github.com/embedthis/goahead/issues/285
Get alerted when CVE-2019-12822 or the next vulnerability affects your stack