What’s Vulnerable › Vulnerabilities
CVE-2019-12826
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-01 · updated 2026-06-17
- Weakness: CWE-352
Description
A Cross-Site-Request-Forgery (CSRF) vulnerability in widget_logic.php in the 2by2host Widget Logic plugin before 5.10.2 for WordPress allows remote attackers to execute PHP code via snippets (that are attached to widgets and then eval'd to dynamically determine their visibility) by crafting a malicious POST request that tricks administrators into adding the code.
Affected products
- Wpchef Widget Logic: before 5.10.2 — fixed in 5.10.2
How to fix
Upgrade to a fixed version: Wpchef Widget Logic 5.10.2. Check the vendor advisory for mitigations.
References
- https://dannewitz.ninja/posts/widget-logic-csrf-to-rce
- https://plugins.trac.wordpress.org/changeset/2112753/widget-logic
- https://wpvulndb.com/vulnerabilities/9403
- https://wpvulndb.com/vulnerabilities/9413
- https://dannewitz.ninja/posts/widget-logic-csrf-to-rce
- https://plugins.trac.wordpress.org/changeset/2112753/widget-logic
- https://wpvulndb.com/vulnerabilities/9403
- https://wpvulndb.com/vulnerabilities/9413
Get alerted when CVE-2019-12826 or the next vulnerability affects your stack