What’s Vulnerable › Vulnerabilities

CVE-2019-12827

Description

Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.

Affected products

How to fix

Upgrade to a fixed version: Digium Asterisk 13.27.0, 15.7.2, 16.4.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-12827 or the next vulnerability affects your stack