What’s Vulnerable › Vulnerabilities
CVE-2019-12830
- Severity: high (CVSS 8.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-15 · updated 2026-06-17
- Weakness: CWE-79
Description
In MyBB before 1.8.21, an attacker can exploit a parsing flaw in the Private Message / Post renderer that leads to [video] BBCode persistent XSS to take over any forum account, aka a nested video MyCode issue.
Affected products
- mybb: before 1.8.21 — fixed in 1.8.21
How to fix
Upgrade to a fixed version: mybb 1.8.21. Check the vendor advisory for mitigations.
References
- https://blog.mybb.com/2019/06/10/mybb-1-8-21-released-security-maintenance-release/
- https://blog.ripstech.com/2019/mybb-stored-xss-to-rce/
- https://blog.mybb.com/2019/06/10/mybb-1-8-21-released-security-maintenance-release/
- https://blog.ripstech.com/2019/mybb-stored-xss-to-rce/
Get alerted when CVE-2019-12830 or the next vulnerability affects your stack