What’s Vulnerable › Vulnerabilities
CVE-2019-12831
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-15 · updated 2026-06-17
- Weakness: CWE-20
Description
In MyBB before 1.8.21, an attacker can abuse a default behavior of MySQL on many systems (that leads to truncation of strings that are too long for a database column) to create a PHP shell in the cache directory of a targeted forum via a crafted XML import, as demonstrated by truncation of aaaaaaaaaaaaaaaaaaaaaaaaaa.php.css to aaaaaaaaaaaaaaaaaaaaaaaaaa.php with a 30-character limit, aka theme import stylesheet name RCE.
Affected products
- mybb: before 1.8.21 — fixed in 1.8.21
How to fix
Upgrade to a fixed version: mybb 1.8.21. Check the vendor advisory for mitigations.
References
- https://blog.mybb.com/2019/06/10/mybb-1-8-21-released-security-maintenance-release/
- https://blog.ripstech.com/2019/mybb-stored-xss-to-rce/
- https://blog.mybb.com/2019/06/10/mybb-1-8-21-released-security-maintenance-release/
- https://blog.ripstech.com/2019/mybb-stored-xss-to-rce/
Get alerted when CVE-2019-12831 or the next vulnerability affects your stack