What’s Vulnerable › Vulnerabilities
CVE-2019-12921
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-18 · updated 2026-06-17
- Weakness: CWE-77
Description
In GraphicsMagick before 1.3.32, the text filename component allows remote attackers to read arbitrary files via a crafted image because of TranslateTextEx for SVG.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- GraphicsMagick: before 1.3.32 — fixed in 1.3.32
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: GraphicsMagick 1.3.32. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00051.html
- http://www.graphicsmagick.org/
- https://github.com/d0ge/data-processing/blob/master/CVE-2019-12921.md
- https://lists.debian.org/debian-lts-announce/2020/03/msg00026.html
- https://www.debian.org/security/2020/dsa-4675
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00051.html
- http://www.graphicsmagick.org/
- https://github.com/d0ge/data-processing/blob/master/CVE-2019-12921.md
- https://lists.debian.org/debian-lts-announce/2020/03/msg00026.html
- https://www.debian.org/security/2020/dsa-4675
Get alerted when CVE-2019-12921 or the next vulnerability affects your stack