What’s Vulnerable › Vulnerabilities
CVE-2019-12923
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-08 · updated 2026-06-17
- Weakness: CWE-352
Description
In MailEnable Enterprise Premium 10.23, the potential cross-site request forgery (CSRF) protection mechanism was not implemented correctly and it was possible to bypass it by removing the anti-CSRF token parameter from the request. This could allow an attacker to manipulate a user into unwittingly performing actions within the application (such as sending email, adding contacts, or changing settings) on behalf of the attacker.
Affected products
- MailEnable: from 6.0 before 6.90; from 7.0 before 7.62; from 8.00 before 8.64; from 9.0 before 9.83; from 10.00 before 10.24 — fixed in 10.24, 6.90, 7.62, 8.64, 9.83
How to fix
Upgrade to a fixed version: MailEnable 10.24, 6.90, 7.62, 8.64. Check the vendor advisory for mitigations.
References
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
Get alerted when CVE-2019-12923 or the next vulnerability affects your stack