What’s Vulnerable › Vulnerabilities
CVE-2019-12924
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-08 · updated 2026-06-17
- Weakness: CWE-311
Description
MailEnable Enterprise Premium 10.23 was vulnerable to XML External Entity Injection (XXE) attacks that could be exploited by an unauthenticated user. It was possible for an attacker to use a vulnerability in the configuration of the XML processor to read any file on the host system. Because all credentials were stored in a cleartext file, it was possible to steal all users' credentials (including the highest privileged users).
Affected products
- MailEnable: from 6.0 before 6.90; from 7.0 before 7.62; from 8.00 before 8.64; from 9.0 before 9.83; from 10.00 before 10.24 — fixed in 10.24, 6.90, 7.62, 8.64, 9.83
How to fix
Upgrade to a fixed version: MailEnable 10.24, 6.90, 7.62, 8.64. Check the vendor advisory for mitigations.
References
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
Get alerted when CVE-2019-12924 or the next vulnerability affects your stack