What’s Vulnerable › Vulnerabilities
CVE-2019-12927
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
MailEnable Enterprise Premium 10.23 was vulnerable to stored and reflected cross-site scripting (XSS) attacks. Because the session cookie did not use the HttpOnly flag, it was possible to hijack the session cookie by exploiting this vulnerability.
Affected products
- MailEnable: from 6.0 before 6.90; from 7.0 before 7.62; from 8.00 before 8.64; from 9.0 before 9.83; from 10.00 before 10.24 — fixed in 10.24, 6.90, 7.62, 8.64, 9.83
How to fix
Upgrade to a fixed version: MailEnable 10.24, 6.90, 7.62, 8.64. Check the vendor advisory for mitigations.
References
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
- http://www.mailenable.com/Premium-ReleaseNotes.txt
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-mailenable/
Get alerted when CVE-2019-12927 or the next vulnerability affects your stack