What’s Vulnerable › Vulnerabilities
CVE-2019-12930
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in noMenu() and noSubMenu() in core/navigation/MENU.php in WIKINDX prior to version 5.8.1 allows remote attackers to inject arbitrary web script or HTML via the method parameter.
Affected products
- Wikindx Project Wikindx: before 5.8.1 — fixed in 5.8.1
How to fix
Upgrade to a fixed version: Wikindx Project Wikindx 5.8.1. Check the vendor advisory for mitigations.
References
- https://sourceforge.net/p/wikindx/code/2787
- https://sourceforge.net/p/wikindx/code/2788
- https://sourceforge.net/p/wikindx/news/2019/07/wikindx-581-released/
- https://sourceforge.net/p/wikindx/code/2787
- https://sourceforge.net/p/wikindx/code/2788
- https://sourceforge.net/p/wikindx/news/2019/07/wikindx-581-released/
Get alerted when CVE-2019-12930 or the next vulnerability affects your stack