What’s Vulnerable › Vulnerabilities
CVE-2019-12951
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-24 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in Mongoose before 6.15. The parse_mqtt() function in mg_mqtt.c has a critical heap-based buffer overflow.
Affected products
- Cesanta Mongoose: before 6.15 — fixed in 6.15
How to fix
Upgrade to a fixed version: Cesanta Mongoose 6.15. Check the vendor advisory for mitigations.
References
- https://github.com/cesanta/mongoose/commit/b3e0f780c34cea88f057a62213c012aa88fe2deb
- https://github.com/cesanta/mongoose/releases/tag/6.15
- https://github.com/cesanta/mongoose/commit/b3e0f780c34cea88f057a62213c012aa88fe2deb
- https://github.com/cesanta/mongoose/releases/tag/6.15
Get alerted when CVE-2019-12951 or the next vulnerability affects your stack