What’s Vulnerable › Vulnerabilities
CVE-2019-13003
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-10 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in GitLab Community and Enterprise Edition before 12.0.3. One of the parsers used by Gilab CI was vulnerable to a resource exhaustion attack. It allows Uncontrolled Resource Consumption.
Affected products
- GitLab: before 12.0.3 — fixed in 12.0.3
How to fix
Upgrade to a fixed version: GitLab 12.0.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/blog/categories/releases/
- https://about.gitlab.com/releases/2019/07/03/security-release-gitlab-12-dot-0-dot-3-released/
- https://about.gitlab.com/blog/categories/releases/
- https://about.gitlab.com/releases/2019/07/03/security-release-gitlab-12-dot-0-dot-3-released/
Get alerted when CVE-2019-13003 or the next vulnerability affects your stack