What’s Vulnerable › Vulnerabilities
CVE-2019-13028
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-28 · updated 2026-06-17
- Weakness: CWE-284
Description
An incorrect implementation of a local web server in eID client (Windows version before 3.1.2, Linux version before 3.0.3) allows remote attackers to execute arbitrary code (.cgi, .pl, or .php) or delete arbitrary files via a crafted HTML page. This is a product from the Ministry of Interior of the Slovak Republic.
Affected products
- Minv Electronic Identification Cards Client: before 3.0.3; before 3.1.2 — fixed in 3.0.3, 3.1.2
How to fix
Upgrade to a fixed version: Minv Electronic Identification Cards Client 3.0.3, 3.1.2. Check the vendor advisory for mitigations.
References
- https://www.csirt.gov.sk/aktualne-7d7.html?id=194
- https://www.csirt.gov.sk/doc/eid_klient_tlacova_sprava.pdf
- https://www.minv.sk/?tlacove-spravy&sprava=pouzivatelom-e-sluzieb-automaticky-aktualizujeme-aplikaciu-pre-elektronicky-obciansky-preukaz
- https://www.csirt.gov.sk/aktualne-7d7.html?id=194
- https://www.csirt.gov.sk/doc/eid_klient_tlacova_sprava.pdf
- https://www.minv.sk/?tlacove-spravy&sprava=pouzivatelom-e-sluzieb-automaticky-aktualizujeme-aplikaciu-pre-elektronicky-obciansky-preukaz
Get alerted when CVE-2019-13028 or the next vulnerability affects your stack