What’s Vulnerable › Vulnerabilities
CVE-2019-13107
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-30 · updated 2026-06-17
- Weakness: CWE-190
Description
Multiple integer overflows exist in MATIO before 1.5.16, related to mat.c, mat4.c, mat5.c, mat73.c, and matvar_struct.c
Affected products
- Fedoraproject Fedora: 31
- tbeu matio: before 1.5.16 — fixed in 1.5.16
How to fix
Upgrade to a fixed version: tbeu matio 1.5.16. Check the vendor advisory for mitigations.
References
- https://github.com/tbeu/matio/compare/f8cd397...fabac6c
- https://github.com/tbeu/matio/pull/118
- https://github.com/tbeu/matio/releases/tag/v1.5.16
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N7AE25FWDBPC7KLVMPLHT4G64O4GISQQ/
- https://github.com/tbeu/matio/compare/f8cd397...fabac6c
- https://github.com/tbeu/matio/pull/118
- https://github.com/tbeu/matio/releases/tag/v1.5.16
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N7AE25FWDBPC7KLVMPLHT4G64O4GISQQ/
Get alerted when CVE-2019-13107 or the next vulnerability affects your stack