What’s Vulnerable › Vulnerabilities
CVE-2019-13117: Uninitialized read in Nokogiri gem
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-01 · updated 2026-06-17
- Weakness: CWE-908
Description
In numbers.c in libxslt 1.1.33, an xsl:number with certain format strings could lead to a uninitialized read in xsltNumberFormatInsertNumbers. This could allow an attacker to discern whether a byte on the stack contains the characters A, a, I, i, or 0, or any other character.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0
- Fedoraproject Fedora: 31
- openSUSE Leap: 15.1
- containers/openjdk: 8-update231
- xmlsoft libxslt: 1.1.33
- Rubygems Nokogiri: before 1.10.5; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+108) — fixed in 1.10.5
How to fix
Upgrade to a fixed version: Rubygems Nokogiri 1.10.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00062.html
- http://www.openwall.com/lists/oss-security/2019/11/17/2
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=14471
- https://gitlab.gnome.org/GNOME/libxslt/commit/c5eb6cf3aba0af048596106ed839b4ae17ecbcb1
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2019/07/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IOYJKXPQCUNBMMQJWYXOR6QRUJZHEDRZ/
- https://oss-fuzz.com/testcase-detail/5631739747106816
- https://security.netapp.com/advisory/ntap-20190806-0004/
- https://security.netapp.com/advisory/ntap-20200122-0003/
- https://usn.ubuntu.com/4164-1/
Get alerted when CVE-2019-13117 or the next vulnerability affects your stack