What’s Vulnerable › Vulnerabilities
CVE-2019-13126
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in NATS Server before 2.0.2 allows a remote attacker to crash the server by sending a crafted request. If authentication is enabled, then the remote attacker must have first authenticated.
Affected products
- nats-io nats-server: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: nats-io nats-server 2.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/nats-io/nats-server/pull/1053
- https://www.twistlock.com/labs-blog/finding-dos-vulnerability-nats-go-fuzz-cve-2019-13126/
- https://github.com/nats-io/nats-server/pull/1053
- https://www.twistlock.com/labs-blog/finding-dos-vulnerability-nats-go-fuzz-cve-2019-13126/
Get alerted when CVE-2019-13126 or the next vulnerability affects your stack