What’s Vulnerable › Vulnerabilities
CVE-2019-13127
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-01 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in mxGraph through 4.0.0, related to the "draw.io Diagrams" plugin before 8.3.14 for Confluence and other products. Improper input validation/sanitization of a color field leads to XSS. This is associated with javascript/examples/grapheditor/www/js/Dialogs.js.
Affected products
- Draw.Io Diagrams: before 8.3.14 — fixed in 8.3.14
- jgraph Mxgraph: through 4.0.0
How to fix
Upgrade to a fixed version: Draw.Io Diagrams 8.3.14. Check the vendor advisory for mitigations.
References
- https://github.com/jgraph/mxgraph/commit/76e8e2809b622659a9c5ffdc4f19922b7a68cfa3
- https://marketplace.atlassian.com/apps/1210933/draw-io-diagrams-for-confluence/version-history
- https://www.syss.de/fileadmin/dokumente/Publikationen/Advisories/SYSS-2019-032.txt
- https://github.com/jgraph/mxgraph/commit/76e8e2809b622659a9c5ffdc4f19922b7a68cfa3
- https://marketplace.atlassian.com/apps/1210933/draw-io-diagrams-for-confluence/version-history
- https://www.syss.de/fileadmin/dokumente/Publikationen/Advisories/SYSS-2019-032.txt
Get alerted when CVE-2019-13127 or the next vulnerability affects your stack