What’s Vulnerable › Vulnerabilities

CVE-2019-13132

Description

In ZeroMQ libzmq before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.3.2, a remote, unauthenticated client connecting to a libzmq application, running with a socket listening with CURVE encryption/authentication enabled, may cause a stack overflow and overwrite the stack with arbitrary data, due to a buffer overflow in the library. Users running public servers with the above configuration are highly encouraged to upgrade as soon as possible, as there are no known mitigations.

Affected products

How to fix

Upgrade to a fixed version: zeromq libzmq 4.0.9, 4.1.7, 4.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-13132 or the next vulnerability affects your stack