What’s Vulnerable › Vulnerabilities
CVE-2019-13137
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-01 · updated 2026-06-17
- Weakness: CWE-401
Description
ImageMagick before 7.0.8-50 has a memory leak vulnerability in the function ReadPSImage in coders/ps.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04, 19.10
- Debian Linux: 10.0
- ImageMagick: before 6.9.10-50; from 7.0.0-0 before 7.0.8-50 — fixed in 6.9.10-50, 7.0.8-50
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-50, 7.0.8-50. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00069.html
- https://github.com/ImageMagick/ImageMagick/commit/35ccb468ee2dcbe8ce9cf1e2f1957acc27f54c34
- https://github.com/ImageMagick/ImageMagick/issues/1601
- https://github.com/ImageMagick/ImageMagick6/commit/7d11230060fa9c8f67e53c85224daf6648805c7b
- https://usn.ubuntu.com/4192-1/
- https://www.debian.org/security/2020/dsa-4712
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00069.html
- https://github.com/ImageMagick/ImageMagick/commit/35ccb468ee2dcbe8ce9cf1e2f1957acc27f54c34
- https://github.com/ImageMagick/ImageMagick/issues/1601
- https://github.com/ImageMagick/ImageMagick6/commit/7d11230060fa9c8f67e53c85224daf6648805c7b
- https://usn.ubuntu.com/4192-1/
- https://www.debian.org/security/2020/dsa-4712
Get alerted when CVE-2019-13137 or the next vulnerability affects your stack