What’s Vulnerable › Vulnerabilities
CVE-2019-13151
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-02 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered in TRENDnet TEW-827DRU firmware before 2.05B11. There is a command injection in apply.cgi (exploitable with authentication) via the action set_sta_enrollee_pin_5g and the key wps_sta_enrollee_pin.
Affected products
- Trendnet AC2600 TEW-827DRU: before 2.05b11 — fixed in 2.05b11
How to fix
Upgrade to a fixed version: Trendnet AC2600 TEW-827DRU 2.05b11. Check the vendor advisory for mitigations.
References
- https://github.com/TeamSeri0us/pocs/blob/master/iot/trendnet/cmdinject3.jpg
- https://github.com/TeamSeri0us/pocs/blob/master/iot/trendnet/cmdinject3.jpg
Get alerted when CVE-2019-13151 or the next vulnerability affects your stack