What’s Vulnerable › Vulnerabilities
CVE-2019-13173
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-02 · updated 2026-06-17
- Weakness: CWE-59
Description
fstream before 1.0.12 is vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hardlink to a file that already exists in the system, and a file that matches the hardlink, will overwrite the system's file with the contents of the extracted file. The fstream.DirWriter() function is vulnerable.
Affected products
- Fstream Project Fstream: before 1.0.12 — fixed in 1.0.12
How to fix
Upgrade to a fixed version: Fstream Project Fstream 1.0.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00052.html
- https://github.com/npm/fstream/commit/6a77d2fa6e1462693cf8e46f930da96ec1b0bb22
- https://usn.ubuntu.com/4123-1/
- https://www.npmjs.com/advisories/886
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00052.html
- https://github.com/npm/fstream/commit/6a77d2fa6e1462693cf8e46f930da96ec1b0bb22
- https://usn.ubuntu.com/4123-1/
- https://www.npmjs.com/advisories/886
Get alerted when CVE-2019-13173 or the next vulnerability affects your stack