What’s Vulnerable › Vulnerabilities
CVE-2019-13189
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-28 · updated 2026-06-17
- Weakness: CWE-79
Description
In Knowage through 6.1.1, there is XSS via the start_url or user_id field to the ChangePwdServlet page.
Affected products
- KnowageLabs Knowage-Server: before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 6.4. Check the vendor advisory for mitigations.
References
- https://blog.contentsecurity.com.au/security-advisory-knowage-cross-site-scripting
- https://blog.contentsecurity.com.au/security-advisory-knowage-cross-site-scripting
Get alerted when CVE-2019-13189 or the next vulnerability affects your stack