What’s Vulnerable › Vulnerabilities
CVE-2019-13240
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-10 · updated 2026-06-17
- Weakness: CWE-640
Description
An issue was discovered in GLPI before 9.4.1. After a successful password reset by a user, it is possible to change that user's password again during the next 24 hours without any information except the associated email address.
Affected products
- glpi-project glpi: before 9.4.1 — fixed in 9.4.1
How to fix
Upgrade to a fixed version: glpi-project glpi 9.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/5da9f99b2d81713b1e36016b47ce656a33648bc7
- https://github.com/glpi-project/glpi/commit/86a43ae47b3dd844947f40a2ffcf1a36e53dbba6
- https://github.com/glpi-project/glpi/compare/1783b78...8e621f6
- https://github.com/glpi-project/glpi/releases/tag/9.4.1
- https://www.synacktiv.com/ressources/advisories/GLPI_9.4.0_unsafe_reset.pdf
- https://github.com/glpi-project/glpi/commit/5da9f99b2d81713b1e36016b47ce656a33648bc7
- https://github.com/glpi-project/glpi/commit/86a43ae47b3dd844947f40a2ffcf1a36e53dbba6
- https://github.com/glpi-project/glpi/compare/1783b78...8e621f6
- https://github.com/glpi-project/glpi/releases/tag/9.4.1
- https://www.synacktiv.com/ressources/advisories/GLPI_9.4.0_unsafe_reset.pdf
Get alerted when CVE-2019-13240 or the next vulnerability affects your stack