What’s Vulnerable › Vulnerabilities
CVE-2019-13470
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-09 · updated 2026-06-17
- Weakness: CWE-125
Description
MatrixSSL before 4.2.1 has an out-of-bounds read during ASN.1 handling.
Affected products
- Inside Secure MatrixSSL: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: Inside Secure MatrixSSL 4.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/matrixssl/matrixssl/blob/4-2-1-open/doc/CHANGES_v4.x.md#changes-between-420-and-421-june-2019
- https://github.com/matrixssl/matrixssl/blob/4-2-1-open/doc/CHANGES_v4.x.md#changes-between-420-and-421-june-2019
Get alerted when CVE-2019-13470 or the next vulnerability affects your stack