What’s Vulnerable › Vulnerabilities
CVE-2019-13506
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
Affected products
- Nuxtjs @Nuxt/Devalue: before 1.2.3 — fixed in 1.2.3
- Nuxtjs Nuxt.Js: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Nuxtjs @Nuxt/Devalue 1.2.3; Nuxtjs Nuxt.Js 2.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/nuxt/devalue/pull/8
- https://github.com/nuxt/devalue/releases/tag/v1.2.3
- https://github.com/nuxt/nuxt.js/commit/0d5dfe71917191c5b07f373896311f2d8f6b75be
- https://github.com/nuxt/nuxt.js/compare/c0776eb...8d14cd4
- https://github.com/nuxt/nuxt.js/releases/tag/v2.6.2
- https://www.npmjs.com/advisories/814
- https://github.com/nuxt/devalue/pull/8
- https://github.com/nuxt/devalue/releases/tag/v1.2.3
- https://github.com/nuxt/nuxt.js/commit/0d5dfe71917191c5b07f373896311f2d8f6b75be
- https://github.com/nuxt/nuxt.js/compare/c0776eb...8d14cd4
- https://github.com/nuxt/nuxt.js/releases/tag/v2.6.2
- https://www.npmjs.com/advisories/814
Get alerted when CVE-2019-13506 or the next vulnerability affects your stack