What’s Vulnerable › Vulnerabilities
CVE-2019-13574
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-12 · updated 2026-06-17
- Weakness: CWE-78
Description
In lib/mini_magick/image.rb in MiniMagick before 4.9.4, a fetched remote image filename could cause remote command execution because Image.open input is directly passed to Kernel#open, which accepts a '|' character followed by a command.
Affected products
- Debian Linux: 9.0, 10.0
- Minimagick Project Minimagick: before 4.9.4 — fixed in 4.9.4
How to fix
Upgrade to a fixed version: Minimagick Project Minimagick 4.9.4. Check the vendor advisory for mitigations.
References
- https://benjamin-bouchet.com/blog/vulnerabilite-dans-la-gem-mini_magick-version-4-9-4/
- https://github.com/minimagick/minimagick/commit/4cd5081e58810d3394d27a67219e8e4e0445d851
- https://github.com/minimagick/minimagick/compare/d484786...293f9bb
- https://github.com/minimagick/minimagick/releases/tag/v4.9.4
- https://lists.debian.org/debian-lts-announce/2019/10/msg00007.html
- https://seclists.org/bugtraq/2019/Jul/20
- https://www.debian.org/security/2019/dsa-4481
- https://benjamin-bouchet.com/blog/vulnerabilite-dans-la-gem-mini_magick-version-4-9-4/
- https://github.com/minimagick/minimagick/commit/4cd5081e58810d3394d27a67219e8e4e0445d851
- https://github.com/minimagick/minimagick/compare/d484786...293f9bb
- https://github.com/minimagick/minimagick/releases/tag/v4.9.4
- https://lists.debian.org/debian-lts-announce/2019/10/msg00007.html
Get alerted when CVE-2019-13574 or the next vulnerability affects your stack