What’s Vulnerable › Vulnerabilities
CVE-2019-13646
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Firefly III before 4.7.17.3 is vulnerable to reflected XSS due to lack of filtration of user-supplied data in a search query. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability
Affected products
- firefly-iii/firefly-iii: before 4.7.17.3 — fixed in 4.7.17.3
How to fix
Upgrade to a fixed version: firefly-iii/firefly-iii 4.7.17.3. Check the vendor advisory for mitigations.
References
- https://github.com/firefly-iii/firefly-iii/compare/a70b7cc...7d482aa
- https://github.com/firefly-iii/firefly-iii/issues/2339
- https://github.com/firefly-iii/firefly-iii/compare/a70b7cc...7d482aa
- https://github.com/firefly-iii/firefly-iii/issues/2339
Get alerted when CVE-2019-13646 or the next vulnerability affects your stack