What’s Vulnerable › Vulnerabilities
CVE-2019-1387
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-18 · updated 2026-06-17
Description
An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. Recursive clones are currently affected by a vulnerability that is caused by too-lax validation of submodule names, allowing very targeted attacks via remote code execution in recursive clones.
Affected products
- git: from 2.14.0 before 2.14.6; from 2.15.0 before 2.15.4; from 2.16.0 before 2.16.6; from 2.17.0 before 2.17.3; from 2.18.0 before 2.18.2; from 2.19.0 before 2.19.3 — fixed in 2.14.6, 2.15.4, 2.16.6, 2.17.3, 2.18.2, 2.19.3
How to fix
Upgrade to a fixed version: git 2.14.6, 2.15.4, 2.16.6, 2.17.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00056.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00003.html
- https://access.redhat.com/errata/RHSA-2019:4356
- https://access.redhat.com/errata/RHSA-2020:0002
- https://access.redhat.com/errata/RHSA-2020:0124
- https://access.redhat.com/errata/RHSA-2020:0228
- https://lists.debian.org/debian-lts-announce/2020/01/msg00019.html
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N6UGTEOXWIYSM5KDZL74QD2GK6YQNQCP/
- https://lore.kernel.org/git/xmqqr21cqcn9.fsf%40gitster-ct.c.googlers.com/T/#u
- https://public-inbox.org/git/xmqqr21cqcn9.fsf%40gitster-ct.c.googlers.com/
- https://security.gentoo.org/glsa/202003-30
Get alerted when CVE-2019-1387 or the next vulnerability affects your stack