What’s Vulnerable › Vulnerabilities
CVE-2019-13952
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-18 · updated 2026-06-17
- Weakness: CWE-787
Description
The set_ipv6() function in zscan_rfc1035.rl in gdnsd before 2.4.3 and 3.x before 3.2.1 has a stack-based buffer overflow via a long and malformed IPv6 address in zone data.
Affected products
- Gdnsd: before 2.4.3; from 3.0.0 before 3.2.1 — fixed in 2.4.3, 3.2.1
How to fix
Upgrade to a fixed version: Gdnsd 2.4.3, 3.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-13952 or the next vulnerability affects your stack