What’s Vulnerable › Vulnerabilities
CVE-2019-13970
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
In antSword before 2.1.0, self-XSS in the database configuration leads to code execution via modules/database/asp/index.js, modules/database/custom/index.js, modules/database/index.js, or modules/database/php/index.js.
Affected products
- Antsword Project Antsword: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: Antsword Project Antsword 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/AntSwordProject/antSword/commit/4b932e81447b4b0475f4fce45525547395c249d3
- https://github.com/AntSwordProject/antSword/compare/ed01dea...834063a
- https://github.com/AntSwordProject/antSword/issues/151
- https://github.com/AntSwordProject/antSword/commit/4b932e81447b4b0475f4fce45525547395c249d3
- https://github.com/AntSwordProject/antSword/compare/ed01dea...834063a
- https://github.com/AntSwordProject/antSword/issues/151
Get alerted when CVE-2019-13970 or the next vulnerability affects your stack