What’s Vulnerable › Vulnerabilities
CVE-2019-13983
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-19 · updated 2026-06-17
- Weakness: CWE-306
Description
Directus 7 API before 2.2.2 has insufficient anti-automation, as demonstrated by lack of a CAPTCHA in core/Directus/Services/AuthService.php and endpoints/Auth.php.
Affected products
- Rangerstudio Directus 7 Api: before 2.2.2 — fixed in 2.2.2
How to fix
Upgrade to a fixed version: Rangerstudio Directus 7 Api 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/directus/api/issues/991
- https://github.com/directus/api/projects/43
- https://github.com/directus/api/issues/991
- https://github.com/directus/api/projects/43
Get alerted when CVE-2019-13983 or the next vulnerability affects your stack