What’s Vulnerable › Vulnerabilities
CVE-2019-1414
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-24 · updated 2026-06-17
Description
An elevation of privilege vulnerability exists in Visual Studio Code when it exposes a debug listener to users of a local computer, aka 'Visual Studio Code Elevation of Privilege Vulnerability'.
Affected products
- Microsoft Visual Studio Code: before 1.39 — fixed in 1.39
- Microsoft Visual Studio Code: all versions
How to fix
Upgrade to a fixed version: Microsoft Visual Studio Code 1.39. Check the vendor advisory for mitigations.
References
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1414
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1414
Get alerted when CVE-2019-1414 or the next vulnerability affects your stack