What’s Vulnerable › Vulnerabilities
CVE-2019-14206
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-21 · updated 2026-06-17
- Weakness: CWE-22
Description
An Arbitrary File Deletion vulnerability in the Nevma Adaptive Images plugin before 0.6.67 for WordPress allows remote attackers to delete arbitrary files via the $REQUEST['adaptive-images-settings'] parameter in adaptive-images-script.php.
Affected products
- Nevma Adaptive Images: before 0.6.67 — fixed in 0.6.67
How to fix
Upgrade to a fixed version: Nevma Adaptive Images 0.6.67. Check the vendor advisory for mitigations.
References
- https://github.com/markgruffer/markgruffer.github.io/blob/master/_posts/2019-07-19-adaptive-images-for-wordpress-0-6-66-lfi-rce-file-deletion.markdown
- https://markgruffer.github.io/2019/07/19/adaptive-images-for-wordpress-0-6-66-lfi-rce-file-deletion.html
- https://wordpress.org/plugins/adaptive-images/#developers
- https://wpvulndb.com/vulnerabilities/9468
- https://github.com/markgruffer/markgruffer.github.io/blob/master/_posts/2019-07-19-adaptive-images-for-wordpress-0-6-66-lfi-rce-file-deletion.markdown
- https://markgruffer.github.io/2019/07/19/adaptive-images-for-wordpress-0-6-66-lfi-rce-file-deletion.html
- https://wordpress.org/plugins/adaptive-images/#developers
- https://wpvulndb.com/vulnerabilities/9468
Get alerted when CVE-2019-14206 or the next vulnerability affects your stack