What’s Vulnerable › Vulnerabilities
CVE-2019-14243
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-23 · updated 2026-06-17
- Weakness: CWE-20
Description
headerv2.go in mastercactapus proxyprotocol before 0.0.2, as used in the mastercactapus caddy-proxyprotocol plugin through 0.0.2 for Caddy, allows remote attackers to cause a denial of service (webserver panic and daemon crash) via a crafted HAProxy PROXY v2 request with truncated source/destination address data.
Affected products
- HAProxy Proxyprotocol: before 0.0.2 — fixed in 0.0.2
How to fix
Upgrade to a fixed version: HAProxy Proxyprotocol 0.0.2. Check the vendor advisory for mitigations.
References
- https://caddy.community/t/dos-in-http-proxyprotocol-plugin/6014
- https://github.com/mastercactapus/caddy-proxyprotocol/issues/8
- https://github.com/mastercactapus/proxyprotocol/commit/5c4a101121fc3e868026189c7a73f7f19eef90ac
- https://github.com/mastercactapus/proxyprotocol/compare/ef496d7...5c4a101
- https://github.com/mastercactapus/proxyprotocol/issues/1
- https://github.com/mastercactapus/proxyprotocol/releases/tag/v0.0.2
- https://caddy.community/t/dos-in-http-proxyprotocol-plugin/6014
- https://github.com/mastercactapus/caddy-proxyprotocol/issues/8
- https://github.com/mastercactapus/proxyprotocol/commit/5c4a101121fc3e868026189c7a73f7f19eef90ac
- https://github.com/mastercactapus/proxyprotocol/compare/ef496d7...5c4a101
- https://github.com/mastercactapus/proxyprotocol/issues/1
- https://github.com/mastercactapus/proxyprotocol/releases/tag/v0.0.2
Get alerted when CVE-2019-14243 or the next vulnerability affects your stack