What’s Vulnerable › Vulnerabilities
CVE-2019-14268
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-25 · updated 2026-06-17
- Weakness: CWE-532
Description
In Octopus Deploy versions 3.0.19 to 2019.7.2, when a web request proxy is configured, an authenticated user (in certain limited circumstances) could trigger a deployment that writes the web request proxy password to the deployment log in cleartext. This is fixed in 2019.7.3. The fix was back-ported to LTS 2019.6.5 as well as LTS 2019.3.7.
Affected products
- Octopus Deploy: from 3.0.19 through 2019.7.2
References
- https://github.com/OctopusDeploy/Issues/issues/5739
- https://github.com/OctopusDeploy/Issues/issues/5739
Get alerted when CVE-2019-14268 or the next vulnerability affects your stack