What’s Vulnerable › Vulnerabilities
CVE-2019-14271
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
- Weakness: CWE-665
Description
In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.
Affected products
- Debian Linux: 10.0
- Docker Engine: from 19.03 before 19.03.1 — fixed in 19.03.1
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Docker Engine 19.03.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00084.html
- https://docs.docker.com/engine/release-notes/
- https://github.com/moby/moby/issues/39449
- https://seclists.org/bugtraq/2019/Sep/21
- https://security.netapp.com/advisory/ntap-20190828-0003/
- https://www.debian.org/security/2019/dsa-4521
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00084.html
- https://docs.docker.com/engine/release-notes/
- https://github.com/moby/moby/issues/39449
- https://seclists.org/bugtraq/2019/Sep/21
- https://security.netapp.com/advisory/ntap-20190828-0003/
- https://www.debian.org/security/2019/dsa-4521
Get alerted when CVE-2019-14271 or the next vulnerability affects your stack