What’s Vulnerable › Vulnerabilities
CVE-2019-14287
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-17 · updated 2026-06-17
- Weakness: CWE-755
Description
In Sudo before 1.8.28, an attacker with access to a Runas ALL sudoer account can bypass certain policy blacklists and session PAM modules, and can cause incorrect logging, by invoking sudo with a crafted user ID. For example, this allows bypass of !root configuration, and USER= logging, for a "sudo -u \#$((0xffffffff))" command.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 29, 30, 31
- NetApp Element Software Management Node: all versions
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 7.5, 7.6, 7.7, 8.1, 8.2, 8.4
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 6.5, 6.6, 7.2, 7.3, 7.4, 7.6 (+3)
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.4, 7.6, 7.7, 8.2 (+1)
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Red Hat OpenShift Container Platform 4.18: 4.1
- RedHat Virtualization: 4.2
- sudo: before 1.8.28 — fixed in 1.8.28
How to fix
Upgrade to a fixed version: sudo 1.8.28. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00047.html
- http://packetstormsecurity.com/files/154853/Slackware-Security-Advisory-sudo-Updates.html
- http://www.openwall.com/lists/oss-security/2019/10/14/1
- http://www.openwall.com/lists/oss-security/2019/10/24/1
- http://www.openwall.com/lists/oss-security/2019/10/29/3
- http://www.openwall.com/lists/oss-security/2021/09/14/2
- https://access.redhat.com/errata/RHBA-2019:3248
- https://access.redhat.com/errata/RHSA-2019:3197
- https://access.redhat.com/errata/RHSA-2019:3204
- https://access.redhat.com/errata/RHSA-2019:3205
- https://access.redhat.com/errata/RHSA-2019:3209
Get alerted when CVE-2019-14287 or the next vulnerability affects your stack