What’s Vulnerable › Vulnerabilities
CVE-2019-14317
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-11 · updated 2026-06-17
- Weakness: CWE-331
Description
wolfSSL and wolfCrypt 4.1.0 and earlier (formerly known as CyaSSL) generate biased DSA nonces. This allows a remote attacker to compute the long term private key from several hundred DSA signatures via a lattice attack. The issue occurs because dsa.c fixes two bits of the generated nonces.
Affected products
- wolfSSL: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: wolfSSL 4.2.0. Check the vendor advisory for mitigations.
References
- https://www.wolfssl.com/docs/security-vulnerabilities/
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2019-14317 or the next vulnerability affects your stack