What’s Vulnerable › Vulnerabilities
CVE-2019-14331
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-28 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in EspoCRM before 5.6.6. Stored XSS exists due to lack of filtration of user-supplied data in Create User. A malicious attacker can modify the firstName and lastName to contain JavaScript code.
Affected products
- espocrm: before 5.6.6 — fixed in 5.6.6
How to fix
Upgrade to a fixed version: espocrm 5.6.6. Check the vendor advisory for mitigations.
References
- http://www.cinquino.eu/EspoCRM.htm
- https://github.com/espocrm/espocrm/commit/4ab7d19776011288b875abd3eef1e1f6f75289e2
- https://github.com/espocrm/espocrm/compare/5.6.5...5.6.6
- http://www.cinquino.eu/EspoCRM.htm
- https://github.com/espocrm/espocrm/commit/4ab7d19776011288b875abd3eef1e1f6f75289e2
- https://github.com/espocrm/espocrm/compare/5.6.5...5.6.6
Get alerted when CVE-2019-14331 or the next vulnerability affects your stack