What’s Vulnerable › Vulnerabilities
CVE-2019-14381
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-476
Description
libopenmpt before 0.4.3 allows a crash due to a NULL pointer dereference when doing a portamento from an OPL instrument to an empty instrument note map slot.
Affected products
- Openmpt Libopenmpt: before 0.4.3 — fixed in 0.4.3
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.4.3. Check the vendor advisory for mitigations.
References
- https://lib.openmpt.org/libopenmpt/2019/02/11/security-update-0.4.3/
- https://lib.openmpt.org/libopenmpt/2019/02/11/security-update-0.4.3/
Get alerted when CVE-2019-14381 or the next vulnerability affects your stack