What’s Vulnerable › Vulnerabilities
CVE-2019-14383
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-617
Description
J2B in libopenmpt before 0.4.2 allows an assertion failure during file parsing with debug STLs.
Affected products
- Openmpt Libopenmpt: before 0.4.2 — fixed in 0.4.2
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.4.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2019/01/22/security-updates-0.4.2-0.3.15-0.2.11253-beta37-0.2.7561-beta20.5-p13-0.2.7386-beta20.3-p16/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2019/01/22/security-updates-0.4.2-0.3.15-0.2.11253-beta37-0.2.7561-beta20.5-p13-0.2.7386-beta20.3-p16/
Get alerted when CVE-2019-14383 or the next vulnerability affects your stack