What’s Vulnerable › Vulnerabilities
CVE-2019-14415
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-29 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in Veritas Resiliency Platform (VRP) before 3.4 HF1. A persistent cross-site scripting (XSS) vulnerability allows a malicious VRP user to inject malicious script into another user's browser, related to resiliency plans functionality. A victim must open a resiliency plan that an attacker has access to.
Affected products
- Veritas Resiliency Platform: before 3.3.2; 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: Veritas Resiliency Platform 3.3.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/153842/Veritas-Resiliency-Platform-VRP-Traversal-Command-Execution.html
- http://seclists.org/fulldisclosure/2019/Jul/39
- https://www.veritas.com/content/support/en_US/security/VTS19-002.html#Issue4
- http://packetstormsecurity.com/files/153842/Veritas-Resiliency-Platform-VRP-Traversal-Command-Execution.html
- http://seclists.org/fulldisclosure/2019/Jul/39
- https://www.veritas.com/content/support/en_US/security/VTS19-002.html#Issue4
Get alerted when CVE-2019-14415 or the next vulnerability affects your stack