What’s Vulnerable › Vulnerabilities
CVE-2019-14433
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-09 · updated 2026-06-17
- Weakness: CWE-209
Description
An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exception, details of the underlying environment may be leaked in the response, and could include sensitive configuration or other data.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 10.0
- OpenStack Nova: before 17.0.12; from 18.0.0 before 18.2.2; from 19.0.0 before 19.0.2 — fixed in 17.0.12, 18.2.2, 19.0.2
- OpenStack: 10, 13, 14
How to fix
Upgrade to a fixed version: OpenStack Nova 17.0.12, 18.2.2, 19.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/08/06/6
- https://access.redhat.com/errata/RHSA-2019:2622
- https://access.redhat.com/errata/RHSA-2019:2631
- https://access.redhat.com/errata/RHSA-2019:2652
- https://launchpad.net/bugs/1837877
- https://lists.debian.org/debian-lts-announce/2022/09/msg00018.html
- https://security.openstack.org/ossa/OSSA-2019-003.html
- https://usn.ubuntu.com/4104-1/
- http://www.openwall.com/lists/oss-security/2019/08/06/6
- https://access.redhat.com/errata/RHSA-2019:2622
- https://access.redhat.com/errata/RHSA-2019:2631
- https://access.redhat.com/errata/RHSA-2019:2652
Get alerted when CVE-2019-14433 or the next vulnerability affects your stack