What’s Vulnerable › Vulnerabilities

CVE-2019-14463

Description

An issue was discovered in libmodbus before 3.0.7 and 3.1.x before 3.1.5. There is an out-of-bounds read for the MODBUS_FC_WRITE_MULTIPLE_REGISTERS case, aka VD-1301.

Affected products

How to fix

Upgrade to a fixed version: libmodbus 3.0.7, 3.1.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-14463 or the next vulnerability affects your stack