What’s Vulnerable › Vulnerabilities

CVE-2019-14491

Description

An issue was discovered in OpenCV before 3.4.7 and 4.x before 4.1.1. There is an out of bounds read in the function cv::predictOrdered<cv::HaarEvaluator> in modules/objdetect/src/cascadedetect.hpp, which leads to denial of service.

Affected products

How to fix

Upgrade to a fixed version: OpenCV 3.0.0 3.4.7, 4.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-14491 or the next vulnerability affects your stack